Editor: Server Error
Incident Report for Screencastify
Resolved
Our Engineering team implemented a fix around 11:10am PT / 1:10pm CT and we have since monitored the progress to ensure stability. We believe this issue is now resolved.

We recommend refreshing Editor and/or logging out and back in to ensure you're able to access Editor. If you continue to experience any additional issues, please contact us at support@screencastify.com

We're so sorry for the impact this issue may have caused you.
Posted Feb 13, 2023 - 13:55 CST
Identified
We're aware that some users are experiencing issues accessing our Editor tool, resulting in a 502 Server Error. We have identified the root cause of this issue and are currently working to implement a solution.
Posted Feb 13, 2023 - 12:28 CST
This incident affected: Screencastify Edit (Video editing).