Intermittent Load Times and/or Error Messages
Incident Report for Screencastify
Resolved
We monitored the implemented fix, and all issues are now resolved. We apologize for the impact this issue may have caused you! If you are still experiencing issues, please contact our Support squad at support@screencastify.com.
Posted Apr 24, 2023 - 14:55 CDT
Monitoring
We were able to identify the root cause and a fix has been implemented. We will monitor for the next hour to confirm full stability.
Posted Apr 24, 2023 - 13:32 CDT
Investigating
Some users may experience long load times and/or receive error messages. Our team is urgently investigating the root cause. We will provide an update once we have more information to share.

Note: Refreshing the page might help.
Posted Apr 24, 2023 - 13:05 CDT
This incident affected: Screencastify Record (Watch Page).