Firebase Hosting
Incident Report for Screencastify
Resolved
November 16, 2020 at 10:29:34 AM GMT-6
The issue with Firebase Hosting has been resolved for all affected projects as of Monday, 2020-11-16 08:29 US/Pacific.

Thank you for your patience! 😄
Posted Nov 16, 2020 - 10:43 CST
Update
Google's Firebase Hosting is experiencing connectivity issues, which is impacting Screencastify and many other services on the internet. Screencastify customers may have trouble accessing the Record extension or the Submit application. We are monitoring Google's response and will post an update by 11am US Central time (GMT-6)
Posted Nov 16, 2020 - 10:20 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2020 - 10:18 CST
Investigating
The Firebase hosting is down causing users to be unable to access the Record extension or the Submit app.
Posted Nov 16, 2020 - 10:00 CST
This incident affected: New recordings, Downloads and exports, and Third party APIs.