Watch Page: Not Able to View Videos
Incident Report for Screencastify
Resolved
After our team implemented a fix, we actively monitored the results to ensure full resolution. We're happy to report viewing videos on the Watch Page has now been restored! 🥳

Thanks for hanging in there as our team implemented a resolution!
Posted Oct 19, 2021 - 17:17 CDT
Identified
Hey there👋

The engineering team has implemented a fix that is still processing that will enable some users to view videos on the Watch Page. We will provide you with another update once the fix has been fully implemented. for all users
Posted Oct 18, 2021 - 16:21 CDT
Update
We are continuing to investigate this issue.
Posted Oct 18, 2021 - 12:15 CDT
Investigating
Hi 👋

We are aware of an issue preventing some users from viewing videos on the Watch Page. 😖
The team has identified the root cause and are working to implement a fix. We assure you, your video(s) are not lost.

In the meantime, please download your videos or share your video with a Google Drive link as a temporary workaround.

We will post an update once the fix has been implemented.
--Screencastify Squad
Posted Oct 18, 2021 - 12:15 CDT
This incident affected: Screencastify Record (Watch Page).