Issues loading videos into Editor
Incident Report for Screencastify
Resolved
Editor tasks are now functioning normally. We will continue to make optimization to the editor to better manage the increased traffic.
Posted Apr 15, 2020 - 08:15 CDT
Monitoring
Increased traffic has led to database operations taking longer than expected. We have implemented some initial optimizations to reduce load and are currently monitoring the impact of those optimizations.
Posted Apr 14, 2020 - 22:08 CDT
This incident affected: Screencastify Edit (Video editing).