Issues Impacting Video Management Page and/or Extension
Incident Report for Screencastify
Resolved
We are happy to report we implemented a fix and monitored it over the last couple of hours. These issues are now resolved. 🎉

Please update to the latest extension version.
Posted Dec 16, 2021 - 12:30 CST
Investigating
Hey there 👋

We're aware that some users are experiencing issues:

1) Video Management Page: Copy Share Link, Interactive Questions & Captions links do not work;
2) Refreshing the page results in a grey screen on Video Management Page and/or My Recordings;
3) Video Management Page: Privacy settings look like they’ve updated, but if you reload the page, the privacy settings did not save;
4) Extension may indicate you are not signed in and does not respond; and/or,
5) Extension freezes.

The team is urgently investigating these issues and has a few fixes ready for deployment. We will provide another update soon.

We are so sorry for the impact these issues may be causing you and your team.

Thanks from the Screencastify Team
Posted Dec 15, 2021 - 14:31 CST
This incident affected: Screencastify Record (Watch Page).