Watch Page Links, Interactive Questions, and Captions: Long Load Times Resulting in Errors
Incident Report for Screencastify
Resolved
We monitored the fix Google implemented and this issue is now considered resolved. We apologize for the impact this issue may have caused you.
Posted Apr 26, 2023 - 16:51 CDT
Monitoring
There was an impact to multiple Google Cloud services causing disruption to our services. We worked closely with Google Support and a solution has been implemented. We will continue to monitor and ensure stability.
Posted Apr 26, 2023 - 14:47 CDT
Investigating
Some users may be experiencing long load times that result in an error, impacting the watch page links, interactive questions, and captions.

In the meantime, you can share the Drive link instead of the Watch Page link.

The team is investigating the issue - we will provide an update once we have more information.
Posted Apr 26, 2023 - 09:57 CDT
This incident affected: Screencastify Record (Watch Page).