Intermittent Load Issues
Incident Report for Screencastify
Resolved
Over the last couple of hours, we monitored the fix and this issue is resolved. We apologize for any impact this may have caused you. If you encounter any other issues, please contact Screencastify Support via support@screencastify.com.
Posted Apr 20, 2023 - 15:47 CDT
Monitoring
We have identified the root cause of this issue and have implemented a solution - load times are now stable. Our engineering team will continue to monitor the outcome of this solution.
Posted Apr 20, 2023 - 13:30 CDT
Investigating
We’re aware that some users are experiencing intermittent load issues logging in and/or accessing our web app. Our engineering team is working to identify the root cause and implement a solution.
Posted Apr 20, 2023 - 12:30 CDT
This incident affected: Screencastify Edit (Video editing), Screencastify Submit (Submit Assignments), and Screencastify Record (Watch Page, New recordings).