Errors with Login
Incident Report for Screencastify
Resolved
We were able to find the issue and resolve it - all users should now be able to log in successfully! 🎉
Posted Nov 18, 2020 - 17:57 CST
Investigating
We are seeing errors with users trying to log into Record, Edit, and Submit. When trying to sign in, you may see a white box (instead of the Record extension), or a "Failed to sign in. Please try again or contact support." error. We're investigating what the cause might be and will provide another update in 30 minutes.
Posted Nov 18, 2020 - 15:57 CST
This incident affected: Screencastify Edit (Video editing), Screencastify Submit (Submit Assignments), and Screencastify Record (New recordings).