Google Classroom playback Issue
Incident Report for Screencastify
Resolved
The Screencastify Team has continued to monitor this situation and it appears that videos in Google Classroom are no longer having playback issues after allowing for some additional processing time. 🥳. All users should be able to send their Screencastify videos to Google Classroom and play them without issue.

Thanks!
-Screencastify Team 😃
Posted Dec 21, 2020 - 16:46 CST
Update
Our team is continuing to closely follow Google Drive's response. As of now, no further progress has been made by their team. If you’re still seeing this issue, please add your voice to this Google Support forum listing here: 🗣here:https://support.google.com/edu/classroom/thread/86856989?hl=en

--Screencastify Squad
Posted Dec 17, 2020 - 14:08 CST
Update
Our team is continuing to closely follow Google Drive's response. As of now, no further progress has been made by their team. If you’re still seeing this issue, please add your voice to this Google Support forum listing here: 🗣here:https://support.google.com/edu/classroom/thread/86856989?hl=en
Posted Dec 16, 2020 - 11:24 CST
Update
Our engineers are continuing to work through this issue, but no progress has yet been made with the Google Drive Team. If you’re still seeing this issue, please add your voice to this Google Support forum listing here: If you are seeing this you can add your voice 🗣 to this issue here:https://support.google.com/edu/classroom/thread/86856989?hl=en
Posted Dec 15, 2020 - 16:54 CST
Update
Our engineers are continuing to work through this issue, but no progress has yet been made with the Google Drive Team. If you’re still seeing this issue, please add your voice to this Google Support forum listing here: If you are seeing this you can add your voice 🗣 to this issue here:https://support.google.com/edu/classroom/thread/86856989?hl=en
Posted Dec 14, 2020 - 12:30 CST
Update
Our engineers are continuing to work through this issue, but no progress has yet been made with the Google Drive Team. If you’re still seeing this issue, please add your voice to this Google Support forum listing here: If you are seeing this you can add your voice 🗣 to this issue here: https://support.google.com/drive/thread/86840466?hl=en
Posted Dec 10, 2020 - 11:25 CST
Update
Our engineers have confirmed at this time, there is nothing new to report.
Posted Dec 10, 2020 - 11:14 CST
Identified
Our engineers have identified a video playback issue with Google Classroom. 😖

The video screen will freeze but the audio track will play without issue. Additionally, there have been issues of the video not being able to be played back or fast forwarded within Google Classroom.

We have identified it to be a Google Drive issue, and have opened a case🕵️‍♂️ with the Google Drive team so that they can identify the root cause and hope they are able to deploy a fix soon. We assure you, your video(s) are not lost.

In the meantime, please download your videos as a workaround.

If you are seeing this you can add your voice 🗣 to this issue here:https://support.google.com/edu/classroom/thread/86856989?hl=en
Posted Dec 09, 2020 - 13:18 CST
This incident affected: Third party APIs.