Submit Assignments Not Uploading
Incident Report for Screencastify
Resolved
We were able to find a resolution and all Submit Assignments should be fully functional again! 😄 🎉
Posted Nov 18, 2020 - 15:42 CST
Update
We believe we have found a solution for Submit Assignments that are getting stuck while submitting and are currently testing to make sure that all issues have been resolved. We will post another update in 60 minutes.
Posted Nov 18, 2020 - 14:14 CST
Identified
Our team is currently working on a fix and we will post another update in 30 minutes.
Posted Nov 18, 2020 - 13:31 CST
Investigating
Screencastify Submit Assignments are not uploading properly, causing users to be unable to submit their videos from the Submit app.
Posted Nov 18, 2020 - 11:29 CST
This incident affected: Screencastify Submit (Submit Assignments).