Video Playback Errors on Watch Page
Incident Report for Screencastify
Resolved
The team implemented a fix at 7:30pm PT / 9:30pm CT and this issue is considered resolved.
Please let us know if you continue to experience any issues by contacting our support team at support@screencastify.com.

We are so sorry for any inconvenience this issue may have caused you or your team.
Posted Jan 02, 2024 - 22:14 CST
Identified
We are aware some users are currently experiencing difficulties with video playback on the Watch Page, encountering either a grey screen or an error message.

Our team has identified the root cause of this issue and is actively working on implementing a solution.
Posted Jan 02, 2024 - 15:17 CST
This incident affected: Screencastify Record (Watch Page).