Some paid subscriptions are seeing the free version of Screencastify
Incident Report for Screencastify
Resolved
Our team successfully identified and implemented a fix for the issue at 11:09am PT / 1:09pm CT. Since the resolution, we've been closely monitoring logs and can confirm that everything is now considered resolved.

We apologize for any inconvenience this may have caused. If you encounter any further issues or have any questions, please don't hesitate to reach out to Screencastify support for assistance.
Posted Mar 13, 2024 - 13:34 CDT
Investigating
We have received reports that some paid users are experiencing access issues and are seeing the free version of Screencastify instead. Our team is actively investigating the issue and working on a solution to resolve it as quickly as possible.

We will provide further updates as soon as more information becomes available.
Posted Mar 13, 2024 - 11:18 CDT
This incident affected: Screencastify Record (New recordings).