Service Disruption
Incident Report for Screencastify
Resolved
Our team has successfully implemented a fix for the reported issues. The resolution was applied at 11 am PT / 1 pm CT, and we have been actively monitoring the system logs since then.

As of now, we have not observed any additional issues, and we consider the reported issues resolved.

Please do not hesitate to reach out to our support team at support@screencastify.com if you have any questions or are experiencing any issues.
Posted Dec 04, 2023 - 15:00 CST
Investigating
We are currently experiencing 4 known issues:

1. Slow Load Times
2. Difficulties Accessing Paid Subscriptions
3. Challenges Accessing or Managing the License Manager Page
4. Errors Submitting the Onboarding Survey

Our team is committed to resolving these issues as quickly as possible, and we appreciate your patience and understanding.

Please stay tuned for further updates.
Posted Dec 04, 2023 - 11:23 CST
This incident affected: Screencastify Record (Watch Page, New recordings).