Edit - Outage Preventing Sign-In
Incident Report for Screencastify
Resolved
Hey thereπŸ‘‹

Our Engineering Team was able to implement a solution and signing in and using the Editor has now been restored! πŸ₯³. All users should be able to sign into the Editor, import their videos, and make any edits.

Thanks for hanging in there as our team implemented a resolution!
- Screencastify Team 😊
Posted Dec 21, 2020 - 16:42 CST
Update
Our Engineering Team has continued monitoring the Editor and all users should be able to open and edit their videos without seeing a blank page or getting stuck on the "Loading your recording" screen.

We will continue to monitor closely over the next few days to ensure that no new issues are introduced and provide another update in 24 hours. πŸ˜„
Posted Dec 16, 2020 - 11:03 CST
Update
Access to the Editor has been restored and all users should be able to open and edit their videos in the Screencastify Editor.

We will continue monitoring the situation and post another update in 24 hours.

Thanks for editing your videos with Screencastify! πŸ€—
Posted Dec 15, 2020 - 10:00 CST
Monitoring
Our Engineering Team was able to implement a solution and access to the Editor has now been restored! All users should be able to access the Editor directly (https://edit.screencastify.com), as well as open their videos in the Editor.

We will continue monitoring and ensure that all issues have been resolved and post another update in twelve hours. In the meantime, happy editing! πŸ˜„
Posted Dec 14, 2020 - 21:57 CST
Update
Our Engineering team is continuing to investigate the issue that is preventing Screencastify users from signing in and using the Editor. Many users may not currently be able to access or sign in to the Editor. You may be seeing a blank page when trying to access the Editor directly, or get stuck on the "Loading your recording" screen when trying to open a Screencastify video in the Editor.

We're so sorry you're not able to access the Editor and will keep investigating to find a solution! We will post an update in twelve hours.
Posted Dec 14, 2020 - 21:37 CST
Investigating
Hey there πŸ‘‹

Beginning at 5:15 PM CST this evening, our Engineers have determined that the Screencastify Editor is experiencing some issues with sign-in. This means you may have some trouble trying to sign-in and use the Editor. We are currently looking into this issue and will post an update in an hour.

Thanks from the Screencastify Team 😊
Posted Dec 14, 2020 - 20:00 CST
This incident affected: Screencastify Edit (Video editing).