Reduced Functionality and Login Issues
Incident Report for Screencastify
Resolved
This incident has been resolved. If you have any questions, please contact us at support@screencastify.com.
Posted May 17, 2024 - 14:58 CDT
Monitoring
We have successfully implemented a fix to address the issues affecting some users. Normal functionality has been restored as of 11am CT.

To see the fix, please update the Screencastify extension to the latest version.

Our team will continue to monitor our logs closely to ensure that the fix remains effective and that no further issues arise.
Posted May 17, 2024 - 12:04 CDT
Identified
There is an issue affecting some users, where they may experience reduced functionality while using Screencastify. This includes instances where users may inadvertently see the free version of Screencastify despite having an upgraded account, as well as encountering difficulties logging in.

Our Engineering team has been actively investigating the issues and working to implement a fix as quickly as possible to restore normal functionality for all affected users.
Posted May 17, 2024 - 10:41 CDT
This incident affected: Screencastify Record (New recordings).