SC-2 Oops Error
Incident Report for Screencastify
Resolved
We have implemented a fix for the SC-2 error issue, and it has been resolved as of 10:30 AM CT. Since then, we have been closely monitoring the situation and can confirm that all logs indicate everything is functioning properly.

Thank you for your patience as we worked through this issue. If you encounter any further problems, please contact us at support@screencastify.com.
Posted Sep 19, 2024 - 11:52 CDT
Identified
Some users are currently experiencing intermittent "Oops! Something went wrong" SC-2 errors when launching the Screencastify extension or attempting to sign in.

Our team has identified the root cause of this issue and is actively working on implementing a fix. We appreciate your patience as we work to resolve this as quickly as possible.
Posted Sep 19, 2024 - 09:20 CDT
This incident affected: Screencastify Record (New recordings).