We will be undergoing scheduled maintenance during this time.
Posted Jul 16, 2026 - 12:07 CDT
Scheduled
Scheduled maintenance will be performed to improve the reliability of the Screencastify platform. While no disruption is expected, some services may be temporarily unavailable during the maintenance window. If you experience issues after the maintenance has concluded, please submit a request through our Help Center or contact Support at support@screencastify.com.
Posted Jul 15, 2026 - 12:06 CDT
This scheduled maintenance affects: Screencastify Edit (Video editing), Screencastify Submit (Submit Assignments), and Screencastify Record (Watch Page, New recordings, Downloads and exports, Third party APIs).