Youtube Down
Incident Report for Screencastify
Resolved
This incident has been resolved.
Posted Nov 16, 2020 - 10:06 CST
Monitoring
Youtube experienced a major outage between 5 pm and 9 pm CST 11/11/2020.
Posted Nov 12, 2020 - 08:59 CST
This incident affected: Screencastify Record (Downloads and exports, Third party APIs).