Service Interruption
Incident Report for Screencastify
Resolved
We're pleased to inform you that our team has successfully implemented a fix, and services are now back to normal. You should no longer experience the previously reported issues.

We appreciate your patience and understanding during this brief interruption. If you encounter any lingering issues or have further concerns, please don't hesitate to reach out to our support team at support@screencastify.com.
Posted Nov 28, 2023 - 15:17 CST
Identified
We are aware that some users are currently experiencing:

1) slow load times;
2) difficulties accessing their paid subscriptions; and/or,
3) accessing or managing the License Manager page.

Our team is actively investigating the issue and has identified the root cause. We are working to implement a fix and restore normal service as quickly as possible.
Posted Nov 28, 2023 - 13:12 CST
This incident affected: Screencastify Record (Watch Page, Downloads and exports).