Intermittent Loading Times
Incident Report for Screencastify
Resolved
This incident is now resolved. We sincerely apologize for any impact this issue may have caused you.
Posted Apr 27, 2023 - 13:56 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2023 - 12:54 CDT
Investigating
We are aware some users may be experiencing long load times, resulting in error messages. Our team is actively investigating the root cause. We will provide an update once we have more information to share.
Posted Apr 27, 2023 - 09:58 CDT
This incident affected: Screencastify Edit (Video editing) and Screencastify Record (Watch Page, New recordings, Downloads and exports).